Bienvenue à Blogs CodeS-SourceS Identification | Inscription | Aide

The Mit's Blog

En plus d'intégrer et skier, il sait même écrire !
(Blog de Renaud Comte)

Actualités


  • Ancien MVP SharePoint 8 ans ...
    Des projets .Net, SharePoint 2013 ou Office 365 ??

    Contactez-nous :

Archives

SP2013 VM install : pénible erreur de Microsoft Setup Bootstrapper

Les installations SharePoint sont toujours une période propre à la découverte. De nouvelles options, voir pire de nouveaux problèmes

Il faut savoir rester humble et surtout garder la tête froide pour bien investiguer le soucis 
Soit éviter de reproduire le problème, voir mieux, savoir le corriger !

J’ai pourtant déployé nombre de VMs SharePoint ces dernières années avec différentes topologies, avoir bien documenté la procédure et investi largement dans le powershell et/ou AutoSpinstaller, il m’arrive encore d’être bloqué.

Un oubli souvent, aller un peu trop vite, de temps à autre, d’ou l’intérêt d’avoir sa “task list” proche de soi.

Soit, en ce qui me concerne, la liste de Tobias Lekman

http://blog.lekman.com/2010/11/automated-sharepoint-2010-installations.html

Cependant, je viens de découvrir une nouvelle erreur :

Failed to install the product: Drive Name:\global\oserver.msi error code: 1603(0x643)

Après quelques recherches rapides, j’ai vite pensé à la configuration de ma VM

A ne jamais oublié : configurer sa VM en premier

  • Jamais de “dynamic memory” pour l’installation !
  • Toujours au minimum, 8 ou 10 GB de RAM pour l’installation !
  • il faut au moins 2 ou 4 cœurs à la VM, pas 1 !

Ensuite, tout revient à la normale d’habitude.

… Mais la non, le soucis reste persistant …

J’ai tenté bien de contrôles,

  • Reprendre une nouvelle ISO de SP2013 SP1
  • Redonner les droits sur les répertoires d’autospinstaller et son iso
  • vérifier les comptes
  • Windows update évidemment.

Rien à faire, impossible de déployer les binaires que ce soit via AutoSPinstaller ou le MSI en direct, toujours la même erreur.

Alors que les autres VMs de ma ferme, front et back ne posait pas de soucis …

Donc après bien des recherches, pas de solution évidente ou que je n’ai pas testé, alors j’ai donc commencé à fouiller dans les commentaires et les liens annexes pour trouver enfin !

Problème de “ArpWrite” avec un code erreur 3 

Pas vraiment de bonne solution si ce n’est d’éditer le Msi, changer de région, passer en standard … non non non

Puis :

http://www.devfacto.com/resolved/ 
(19 mai 2015)

Il semble qu’un admin plus téméraire qui a constaté ce soucis assez aléatoire est allé chercher le support MS officiel pour trouver.
>>> et ils ont trouvé !!!

Unsatisfied with the workarounds (read MSIBreak or the ORCA tool or changing the number of processors), and after having updated Windows with the latest patches, I called Microsoft and worked for weeks with their engineers at diagnosing the root issue of the problem, which for us was:

The SharePoint ArpWrite action (registering SharePoint 2013 as installed in the registry) attempted to access a missing registry key at HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer

So to resolve this, we wrote the following PowerShell script (run as Administrator):

###
if(!(Test-Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer)){
New-Item -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer | Out-Null
}
$regProps = Get-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer
if(! $regProps.logging){
New-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer -Name logging -Value voicewarmup -PropertyType String | Out-Null
}
if(! $regProps.debug){
New-ItemProperty -Path HKLM:\SOFTWARE\Policies\Microsoft\Windows\Installer -Name debug -Value 3 -PropertyType DWord | Out-Null
}
###

And much to our shock, the installation succeeded!

J’ai repris le script et tout a fonctionné aussitôt !
(Il manquait 2 clé de registres … vivement un patch et une meilleur explication mais bon)

Je profite donc de mon blog pour reprendre la solution et remercier son auteur Dragan Radovic au passage

Bon install à tous

Renaud Comte aka TheMit
“Plus j’installe SP, plus j’apprécie 365 Sourire

Ce post vous a plu ? Ajoutez le dans vos favoris pour ne pas perdre de temps à le retrouver le jour où vous en aurez besoin :
Posted: jeudi 20 août 2015 11:43 par themit
Classé sous : , ,

Commentaires

Pas de commentaires

Les commentaires anonymes sont désactivés

Les 10 derniers blogs postés

- Merci par Blog de Jérémy Jeanson le 10-01-2019, 20:47

- Office 365: Script PowerShell pour auditer l’usage des Office Groups de votre tenant par Blog Technique de Romelard Fabrice le 04-26-2019, 11:02

- Office 365: Script PowerShell pour auditer l’usage de Microsoft Teams de votre tenant par Blog Technique de Romelard Fabrice le 04-26-2019, 10:39

- Office 365: Script PowerShell pour auditer l’usage de OneDrive for Business de votre tenant par Blog Technique de Romelard Fabrice le 04-25-2019, 15:13

- Office 365: Script PowerShell pour auditer l’usage de SharePoint Online de votre tenant par Blog Technique de Romelard Fabrice le 02-27-2019, 13:39

- Office 365: Script PowerShell pour auditer l’usage d’Exchange Online de votre tenant par Blog Technique de Romelard Fabrice le 02-25-2019, 15:07

- Office 365: Script PowerShell pour auditer le contenu de son Office 365 Stream Portal par Blog Technique de Romelard Fabrice le 02-21-2019, 17:56

- Office 365: Script PowerShell pour auditer le contenu de son Office 365 Video Portal par Blog Technique de Romelard Fabrice le 02-18-2019, 18:56

- Office 365: Script PowerShell pour extraire les Audit Log basés sur des filtres fournis par Blog Technique de Romelard Fabrice le 01-28-2019, 16:13

- SharePoint Online: Script PowerShell pour désactiver l’Option IRM des sites SPO non autorisés par Blog Technique de Romelard Fabrice le 12-14-2018, 13:01