Hier soir, j'ai reçu un un mail d'un membre qui rencontrait des problèmes pour surfer sur une certaine section de CodeS-SourceS.
Il utilisait Firefox. Alors j'ai ouvert Firefox et j'ai testé (oui j'ai un Firefox sur ma machine que j'ouvre pour tester). Cela fonctionnait chez moi, bref rien de si étrange.
Je recois un coup de tel, le temps de finir le coup de fil, je retourne sur mon pc et qu'est-ce que j'ai qui s'affiche ?
Ceci :
Mise à jour forcée de Firefox

J'ai eu beau chercher partout dans les options, nul part j'ai trouvé une options disant un truc du genre "mettre à jour automatiquement Firefox sans rien me demander et prennez le risque de me pourrir ma machine avec une version toute fraîche dont on en connait pas grand chose"
Ce qui me gêne ce n'est pas la mise à jour automatique, cela peut être considéré comme une bonne mesure sécuritaire sauf que si la nouvelle version a des problèmes (pour X raisons) et bien je vais avoir une version que je n'aurai pas demandé.
Au moins windows update (voir même ClickOnce) il est très simple d'activer/modifier la façon de récupérer/installer les mises à jour. Et la je constate que dans FF c'est caché je ne sais ou (et encore si cette option existe)

Ha on me dit dans l'orreillette que cette option existe dans options/avancé/mise à jour et par défaut les mises à jour automatiques.
J'aurai préféré qu'on me demande mon avis sur le sujet au 1er lancement par exemple, un peu comme windows update qui demande à être paramétré après une installe toute neuve.

Exemple tout bête, imaginons que des users rencontrent des problèmes avec la version précédente qui n'est plus sur mon poste et que cela ne foire pas avec ma version. Je fais quoi ? Je passe 2h à faire comme un certain A. V. à chercher dans les archives et de tout réinstaller.

Bref certains verrons une critique innadmissible sur Firefox, d'autres m'insulteront surement, peut-être que certains approuveront mais dans tous les cas on ne m'enlèvera pas de la tête que cela serait sympa de la part de Firefox de proposer au 1er lancement la façon de gérer les mises à jour. (Qu'on soit bien d'accord, je n'ai rien contre cette feature bien au contraire, pour l'utilisateur de base ça peut s'avérer utile)

P.S : Désormais, vous l'aurez compris, si vous avez un pb pour surfer sur CS et que vous êtes en FF 1.5.0.0 pas la peine de m'envoyer un mail, installez d'abord la 1.5.0.1 et on pourra discuter

Ce post vous a plu ? Ajoutez le dans vos favoris pour ne pas perdre de temps à le retrouver le jour où vous en aurez besoin :