Pour completer l'approche, voici un article sur les compatibilités entre 1.1 et 2.0 beta

Microsoft .NET Framework 1.1 and 2.0 (Beta) Compatibility

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnnetdep/html/netfxcompat.asp