Bienvenue à Blogs CodeS-SourceS Identification | Inscription | Aide

Problème d’utilisation du serveur de développement ASP.NET sous Vista

Le problème rencontré est le suivant :

Lorsqu’on exécute un site web (une page aspx quelconque) à partir de Visual Studio, le serveur de développement ASP.NET s’exécute mais Internet Explorer renvoie le message suivant :

image

Pour résoudre le problème, suivez la procédure suivante :

  • Exécutez le Bloc-notes de Windows en tant qu’administrateur.
  • Ouvrez le fichier C:\Windows\System32\drivers\etc\hosts
  • Changez la ligne “::1             localhost” en “:::1             localhost” c’est-à-dire en rajoutant encore deux points (:) devant le chiffre 1.
  • Sauvegardez le fichier en cliquant Fichier > Enregistrer sous puis en sélectionnant le type Tous les fichiers :

image

  • Répondez Oui à la question qui vous est posé pour écraser le fichier existant avec les changements.

 

Si vous avez un problème plus spécifique concernant le fonctionnement du serveur de développement ASP.NET, vous trouverez ici quelques pistes de réflexion/solution : http://msdn.microsoft.com/fr-fr/library/w566a94d.aspx

Ce post vous a plu ? Ajoutez le dans vos favoris pour ne pas perdre de temps à le retrouver le jour où vous en aurez besoin :
Posted: jeudi 12 mars 2009 17:23 par bianca
Classé sous :

Commentaires

RaptorXP a dit :

Ce probleme est du a la mise a jour de mardi dernier de Windows Defender.

# mars 12, 2009 17:56

Nix a dit :

J'ai eu le même pb il y a 2 jours...

J'ai passé des heures à trouver le truc en désinstallant les derniers trucs que j'avais installé pensant que le pb venait d'un autre logiciel...

Bravo Microsoft et merci de m'avoir fait perdre un temps fou pour une telle connerie. Deja que Vista c'est pas un cadeau mais alors si en plus ils nous foutent des batons dans les roues sans prévenir pour coder tranquillement, on est pas rendu...

# mars 12, 2009 20:49

Nix a dit :

Ce que j'aimerai savoir c'est pourquoi ils ont décidé de forcer un tel changement sans prévenir...

Moi j'ai mis 127.0.0.1 à la place des ::1, et ça marche très bien ainsi.

# mars 12, 2009 20:51

KooKiz a dit :

C'est pas une notation ipv6 ça ?

# mars 13, 2009 09:48

bianca a dit :

Je crois oui en effet mais je n'ai pas réussi à trouver quelque part une explication claire sur le sujet.

# mars 13, 2009 09:55

christian a dit :

Oui 127.0.0.1 c'est l'IPv4 local, et ::1 c'est la variante IPv6.

Attention le ::1 fonctionnera si la couche IPv6 est active, ce qui est le cas par défaut justement sous Vista.

# mars 15, 2009 13:26
Les commentaires anonymes sont désactivés

Les 10 derniers blogs postés

- Merci par Blog de Jérémy Jeanson le 10-01-2019, 20:47

- Office 365: Script PowerShell pour auditer l’usage des Office Groups de votre tenant par Blog Technique de Romelard Fabrice le 04-26-2019, 11:02

- Office 365: Script PowerShell pour auditer l’usage de Microsoft Teams de votre tenant par Blog Technique de Romelard Fabrice le 04-26-2019, 10:39

- Office 365: Script PowerShell pour auditer l’usage de OneDrive for Business de votre tenant par Blog Technique de Romelard Fabrice le 04-25-2019, 15:13

- Office 365: Script PowerShell pour auditer l’usage de SharePoint Online de votre tenant par Blog Technique de Romelard Fabrice le 02-27-2019, 13:39

- Office 365: Script PowerShell pour auditer l’usage d’Exchange Online de votre tenant par Blog Technique de Romelard Fabrice le 02-25-2019, 15:07

- Office 365: Script PowerShell pour auditer le contenu de son Office 365 Stream Portal par Blog Technique de Romelard Fabrice le 02-21-2019, 17:56

- Office 365: Script PowerShell pour auditer le contenu de son Office 365 Video Portal par Blog Technique de Romelard Fabrice le 02-18-2019, 18:56

- Office 365: Script PowerShell pour extraire les Audit Log basés sur des filtres fournis par Blog Technique de Romelard Fabrice le 01-28-2019, 16:13

- SharePoint Online: Script PowerShell pour désactiver l’Option IRM des sites SPO non autorisés par Blog Technique de Romelard Fabrice le 12-14-2018, 13:01